How to fix «Setting locale failed»?

installation

(Dmitry Fedyuk) #1

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LANG = "ru_RU.UTF-8"
are supported and installed on your system.


How to fix «Error: Config owner (postgres:107) and data owner (root:0) do not match, and config owner is not root»?
(Dmitry Fedyuk) #2

Step 1

docker container prune

Step 2

rm -rf /usr/local/discourse

Step 3

Start a new installation from the beginning.

Step 4

Set the en_US.UTF-8 value for the en. LANG option in your <container>.yml.

env:
  LANG: en_US.UTF-8

Details: meta.discourse.org/t/44876/5

Step 5

./launcher rebuild `<container>